Welcome, Guest. Please login or register.
Did you miss your activation email?

Recent Posts

Pages: 1 ... 8 9 [10]
91
Discussion | Обсуждение / Re: "new LimeReport" takes 30~40 seconds!
« Last post by alexyuisme on April 13, 2021, 04:36:34 PM »
One crash log lib requires elf info thus lots of debug libs are included in the deployment environment folder. Are those debug libs problematic?

Alex
92
Discussion | Обсуждение / Re: "new LimeReport" takes 30~40 seconds!
« Last post by Subst on April 13, 2021, 04:09:35 PM »
alexyuisme, Why in your environment release libraries are mixing with debug ones?
93
Discussion | Обсуждение / Re: "new LimeReport" takes 30~40 seconds!
« Last post by alexyuisme on April 13, 2021, 03:44:10 PM »
Additional dlls look-ups include: libGLESV2d.dll, libopenblas.dll. I uploaded a video to show the launch time on my ssd takes about 22 seconds:

https://github.com/alexyuisme/test_limereport/blob/master/2021-04-12%2022-02-49.mkv

Alex
94
Discussion | Обсуждение / Re: "new LimeReport" takes 30~40 seconds!
« Last post by Subst on April 13, 2021, 02:34:53 PM »
alexyuisme, I've run the test from hdd
from sdd rather faster

I have the sysinternals suite.
What exactly libraries are irrelevant you think?
95
Discussion | Обсуждение / Re: Slow startup time!
« Last post by alexyuisme on April 13, 2021, 06:18:30 AM »
Hi,
Please follow the Arin's advice. Load the report just before the generation.
If you load it when you create form then it's slow...

Regards,
Mucip:)

Hi Mucip,

Thank you
I will try your advice soon

Best Regards

Hi, francois :

I have a similar issue as you did regarding the slow startup time. Did you solve this issue?

Thanks,
Alex
96
Discussion | Обсуждение / Re: "new LimeReport" takes 30~40 seconds!
« Last post by alexyuisme on April 12, 2021, 12:48:39 PM »
To confirm my theory, I used "processing explorer" to check which dlls will be accessed during the exe program startup. I found that the exe is trying to access some of the irrelevant dlls within the directory!

I don't know who is forcing this behavior but the program really does this kind of unnecessary dll-lookups.

To download process explore, here is the link:|

https://download.sysinternals.com/files/ProcessExplorer.zip

to enter view dll mode:

1. On the View menu make sure “Show Lower Pane” is checked.
2. Press CTRL + D or click View - Lower Pane View - DLLs to enable DLL view mode.

Alex
97
Discussion | Обсуждение / Re: "new LimeReport" takes 30~40 seconds!
« Last post by alexyuisme on April 12, 2021, 06:01:59 AM »
I did try running .exe under env1/env2 on ssd with antivirus disabled. Here's the result:

env1: 2.2 secs;
env2: 9~10 secs;

The launch speed is way faster than hdd. Tried a couple times and the result is firmed.

I know it makes zero sense, but here the launch time increases with the number of dlls increases in the exe's directory.

Thanks,
Alex
98
Discussion | Обсуждение / Re: "new LimeReport" takes 30~40 seconds!
« Last post by alexyuisme on April 12, 2021, 03:48:23 AM »
I did run .exe in env2 with antivirus disabled. The program was still slow to start.

One question: Did you run the test program on ssd or hdd? Our computers use hdd.

Thanks,
Alex
99
Discussion | Обсуждение / Re: "new LimeReport" takes 30~40 seconds!
« Last post by alexyuisme on April 12, 2021, 03:36:38 AM »
Parts of our software require opencv3. Does it hurt anything?

Alex
100
Discussion | Обсуждение / Re: "new LimeReport" takes 30~40 seconds!
« Last post by Subst on April 10, 2021, 09:19:07 PM »
P.S. you are using the opencv as I see
why the 3-d version not 4-th?
Pages: 1 ... 8 9 [10]