Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Problems with Linux Appimage  (Read 457 times)

ham13

  • Newbie
  • *
  • Posts: 27
    • View Profile
Problems with Linux Appimage
« on: November 05, 2022, 05:53:13 PM »
Hello All,

I am running  Linux Mint 20.3 64 bit in a virtual box on Windows 8.1. I have loaded LRDesigner_1_4_7-64bit.appimage file. When I run the image LRDesigner opens and I am able to start a new report. The problem is when I click on report bands the drop down list is blank. This also happens when I right click on a text field. If I double click, as I should, It works properly but, not  :)with the band tool. If I click randomly on the band drop down I get a band on the report. Then the program locks up.

What is the fix? Am I missing a component in Linux?

Further if I try to compile it with QtCreator 8.0.1 the following errors occur:

:-1: error: cannot find -llimereport
:-1: error: cannot find -lQtZint
:-1: error: linker command failed with exit code 1 (use -v to see invocation)
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [Makefile:160: ../build/5.12.8/linux64/release/designer/LRDesigner] Error 1
:-1: Error while building/deploying project designer (kit: Desktop)
Error while building/deploying project designer (kit: Desktop)
When executing step "Make"
:-1: error: Project ERROR: Unknown module(s) in QT: designercomponents-private

the build is unsuccessful. Checked the net and cannot find designercomponents-private.
So what do I do now to get LRDesigener to run properly?

Looks like a great tool if we can get it to run.

Thanks

Arin Alex

  • Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 992
    • View Profile
Re: Problems with Linux Appimage
« Reply #1 on: November 08, 2022, 05:30:40 PM »
Quote
The problem is when I click on report bands the drop down list is blank.
I will check it. Possible is needed to create new AppImage for new linux versions.
Quote
Further if I try to compile it with QtCreator 8.0.1 the following errors occur:
Have you tried to build source codes from https://github.com/fralx/LimeReport?

ham13

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Problems with Linux Appimage
« Reply #2 on: November 09, 2022, 12:33:03 AM »
Downloaded files from Sourceforge. Here are the errors I get when compiling with QtCreator. I think I tried both version 3 and version 2. Downloaded from website home page. I'll try to download from github and see what happens.
Will post results.

Using QtCreator in a Linux Mint 20.3 virtual machine running on Window 8.1
Further if I try to compile it with QtCreator 8.0.1 the following errors occur:

👎 error: cannot find -llimereport
👎 error: cannot find -lQtZint
👎 error: linker command failed with exit code 1 (use -v to see invocation)
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [Makefile:160: ../build/5.12.8/linux64/release/designer/LRDesigner] Error 1
👎 Error while building/deploying project designer (kit: Desktop)
Error while building/deploying project designer (kit: Desktop)
When executing step "Make"
👎 error: Project ERROR: Unknown module(s) in QT: designercomponents-private

the build is unsuccessful. Checked the net and cannot find designercomponents-private.
So what do I do now to get LRDesigener to run properly?

Thanks

ham13

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Problems with Linux Appimage
« Reply #3 on: November 09, 2022, 03:39:38 AM »
Downloaded Lime Report 1.5.35 from GitHub. Tried to compile limereport.pro with QtCreator on Miint 20.3 Linux. Configuration and build failed.

Error: -1: error: Project ERROR: Unknown module(s) in QT: designercomponents-private

Marty :(


Arin Alex

  • Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 992
    • View Profile
Re: Problems with Linux Appimage
« Reply #4 on: November 09, 2022, 03:16:03 PM »
if you installed qt from the linux repository you have to also install packages with qt private headers

ham13

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Problems with Linux Appimage
« Reply #5 on: November 09, 2022, 06:00:10 PM »
Thanks for your response. I installed Qt using the Qt installer downloaded from qtio
 (qt-unified-linux-x64-4.2.2-online.run). Would you please tell me where and how to install the package
"qt private headers". Do I use the maintenance tool to add additional components and if so which ones? I'm still new at this and need a little more guidance.

Thanks
 

ham13

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Problems with Linux Appimage
« Reply #6 on: November 09, 2022, 06:43:28 PM »
Installed qtbase5-private-dev. This pacakge contains qtbase private devel files. No change.

Marty

Arin Alex

  • Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 992
    • View Profile
Re: Problems with Linux Appimage
« Reply #7 on: November 09, 2022, 08:04:16 PM »
Quote
I installed Qt using the Qt installer downloaded from qtio
It's very strange that you have a problem with private headers in case when you installed qt via installer.
Check in QtCreator if the right qt kit is used for building limereport
Quick fix: add CONFIG *= no_formdesigner to common.pri

ham13

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Problems with Linux Appimage
« Reply #8 on: November 09, 2022, 09:42:17 PM »
The kits I have in QtCreator are Desktop and replacement for Desktop Qt 6.3.2 GCC 64 Bit. QtCreator is V 8.0.1 - qt6. Wrong version? The last fix adding "CONFIG *= no_formdesigner to common.pri" worked with lots of warnings but, nothing fatal. I was able to compile a release version and run it.

Regarding the appimage I found the problem was the missing Linux component openGL. When I added it; the contents of the dropdowns appeared and appear to function properly.

I'm still not sure why LDR would not compile. Perhaps some problem with Qt6 versus Qt5.
Glad that it runs now and I can get to creating some reports from MySQL.

Thank you for your patience and help! :)

Marty