Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Using LimeReport 1.5.87 on RaspberryPi 4 x64?  (Read 181 times)

Mucip

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
Using LimeReport 1.5.87 on RaspberryPi 4 x64?
« on: December 06, 2022, 09:29:06 PM »
Hi,
I want to use LimeReport in RaspberryPi 4 x64. When I compile below errors and warning appear:

:-1: warning: Project WARNING: CONFIG+=uitools is deprecated. Use QT+=uitools instead.
:-1: error: Project ERROR: Unknown module(s) in QT: designercomponents-private

How can I compile and use LimeReport with my programs on RaspberryPi 4 x64?



Regards,
Mucip:)

Arin Alex

  • Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 973
    • View Profile
Re: Using LimeReport 1.5.87 on RaspberryPi 4 x64?
« Reply #1 on: December 07, 2022, 03:58:11 AM »
Hi
Try to add CONFIG *= no_formdesigner to the beginning of the file common.pri and rebuild.

Mucip

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
Re: Using LimeReport 1.5.87 on RaspberryPi 4 x64?
« Reply #2 on: December 07, 2022, 10:31:31 AM »
Hi Arin,
Firstly I install with
$sudo apt-get install qttools5-private-dev

In this case ERROR disappeared

I added at the top of common.pri your suggestion "CONFIG *= no_formdesigner"

But warning still there?!

Regards,
Mucip:)

Subst

  • Sr. Member
  • ****
  • Posts: 421
    • View Profile
Re: Using LimeReport 1.5.87 on RaspberryPi 4 x64?
« Reply #3 on: December 07, 2022, 01:03:27 PM »
just try to change

Code: [Select]
if(equals(QT_MAJOR_VERSION, 5) : greaterThan(QT_MINOR_VERSION, 1)) | equals(QT_MAJOR_VERSION, 6) {
    SUBDIRS += console \
        lrdview

}

to

Code: [Select]
if(equals(QT_MAJOR_VERSION, 5) : greaterThan(QT_MINOR_VERSION, 1)) | equals(QT_MAJOR_VERSION, 6) {
    SUBDIRS += console
}

in limereport.pro

or if you need to build lrdview

change the lrdview.pro

Code: [Select]
CONFIG += uitools
to

Code: [Select]
equals(QT_MAJOR_VERSION, 4) {
    CONFIG += uitools
}

equals(QT_MAJOR_VERSION, 5) | equals(QT_MAJOR_VERSION, 6) {
    QT += uitools
}

Mucip

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
Re: Using LimeReport 1.5.87 on RaspberryPi 4 x64?
« Reply #4 on: December 07, 2022, 01:59:28 PM »
Hi,
I don't know what is and what for lrdview? But in anycase I applied your second suggestion.
Now, no warning and no error at all.  ;)
Thanks a lot.

Regards,
Mucip:)